您所在的位置:首页 待评仓库 【价值1元】discuz多国语言切换 主程序GBK2.7(tshuz_lang)

[待评] discuz多国语言切换 主程序GBK2.7

兼容版本:X3X3.1X3.2X3.3X3.4F1.0L1.0GBK

演示截图 Ps:该应用还在待发仓库,处于未发状态
应用介绍

功能简介


为你的discuz快速切换语言,拥有史上最全的语言包系统。用户自主切换

????【重要】 插件安装必读下方安装步骤!????

插件介绍


本插件不含语言包、需按照下方安装流程进行安装,否则不提供售后!
1.用户实现自主切换系统语言;
2.后台可设置初始化语言;
3.插件需绑定安装扩展语言包,请安装的时候务必选择【是】;
4.GBK由于编码问题,只支持德语,英语,法语和简体中文,UTF8支持所有语言;
5.插件使用出现问题请到  及时反馈,应用中心不做解答

安装步骤:


1.首先安装本插件后启用;
2.按照设置插件
3.安装对应语言包(具体语言包可看);
4.将sourc/language/语言包移动至source/plugin/tshuz_lang/language中;
5.安装该扩展,不安装插件将无效果
6.后台,工具,更新缓存。
7.不想使用请参考、

常见问题:


问:插件安装成功,只有一个语言?
答:插件需要自己选择语言包安装,多安装一个语言包,多一种语言。

问:已经选择安装了语言包,为什么没法切换?
答:没有正确按照安装说明安装扩展http://addon.discuz.com/[email protected]_language.pack

问:安装提示目录权限不足,请问有哪些目录需要给权限?
答:source/language和source/plugin/tshuz_lang都要给足权限777,包括子目录和文件权限

问:安装流程正确的,为什么不显示其他语言的图标?
答:应用中心机制存在问题,你可以查看source/plugin/tshuz_lang下是否有两个字母的文件夹,例如:en,移动到source/plugin/tshuz_lang/language目录里

问:语言包存在错误?
答:本插件不负责语言包翻译工作,具体可在对应语言包页面向语言包翻译团队反馈。

问:为什么之前使用正常添加了新的语言就不能切换了?
答:请重新安装

注意事项:


1. 安装之前自行备份source/language目录;
2. 插件语言包为组件形式,根据自己实际需求购买安装;
3. 插件免费提供GBK简体中文语言包和UTF8繁体中文语言包;
4. 请安装启用后立刻设置默认语言包。
5. 插件需要一定的服务器能力,虚拟主机或服务器性能较差的请勿安装!

安装须知:


1. 您购买的仅仅是使用权,而不是拥有权;
2. 本插件建议您对特殊版块开启;
3. 一旦购买表示认同本协议和科站网授权协议,概不退款;
4. 未尽述事宜可联系客服咨询,最终解释权归科站网所有。

演示图片

更多插件http://addon.discuz.com/[email protected]
见下图
更新日志

2.7 更新日志

显示代码游湖

主程序GBK2.6 更新日志

代码更新

2016/02/24 更新内容


新增未安装内核文件,不显示效果,防误操作

//20151214
更新变量名重复造成的错误

20151008更新说明


应语言包翻译团队要求,更改语言包结构,不影响原有安装使用用户

20150831更新说明


  • 修复繁体中文图标重复的问题
  • 新增语言切换文字提醒
  • 新增图标对应语言文字
  • 新增GBK支持繁体中文
  • 新增GBK支持俄语


更新时间


2015年8月28日

更新内容


  • 配合扩展,精简扩a展代码
  • 新增后台版块语言设置
  • 更改显示判断方式
  • 更新安装说明
  • 为后续扩展功能铺垫基础

免责声明

源码哥所发布的一切破解应用及应用的解密分析文章仅限用于学习和研究目的;不得将上述内容用于商业或者非法用途,否则,一切后果请用户自负。本站信息来自网络,版权争议与本站无关。您必须在下载后的24个小时之内,从您的电脑中彻底删除上述内容。如果您喜欢该应用,请支持正版,购买正版,得到更好的正版服务。(如有侵犯了您权益的应用请点此处联系我们处理

源码哥(ymg6.com) ( 浙ICP备16035663号-1 )
Processed in 0.062656 s, 9 queries  Archiver     
返回顶部